const regex = /<property[^>]*name="(username|password)".*?</property>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<property[^>]*name="(username|password)".*?<\/property>', 'g')
const str = `<property name="password">QWERTY</property><property name="username">Hello</property><property name="passive">1</property><property name="password">Test Password</property><property name="scheme">smb</property><property name="timeout">10000</property><property name="username">RANDOM USER</property><property name="username">Sid</property>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);