$re = '/<property[^>]*name="(username|password)".*?</property>/';
$str = '<property name="password">QWERTY</property><property name="username">Hello</property><property name="passive">1</property><property name="password">Test Password</property><property name="scheme">smb</property><property name="timeout">10000</property><property name="username">RANDOM USER</property><property name="username">Sid</property>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;