# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\||\|$/s3:\/\/dcloud-chsdev\/INCOMING\/CASE_FILES\/TEST\/SAD20200508000017\/EGY-2020-0116\/output\/domain_object.json/mg;t' <<< "s3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json"