import Foundation
let pattern = #"^\||\|$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"s3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"s3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)