$re = '/^\||\|$/m';
$str = 's3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json';
$subst = "s3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;