use strict;
my $str = 's3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json';
my $regex = qr/^\||\|$/mp;
my $subst = 's3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";