import re
regex = re.compile(r"^\||\|$", flags=re.MULTILINE)
test_str = "s3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json"
subst = "s3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json"
result = regex.sub(subst, test_str)
if result:
print(result)