const regex = /^\||\|$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\||\\|$', 'mg')
const str = `s3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json`;
const subst = `s3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);