re = /^\||\|$/m
str = 's3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json'
subst = 's3://dcloud-chsdev/INCOMING/CASE_FILES/TEST/SAD20200508000017/EGY-2020-0116/output/domain_object.json'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result