using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"50F:(?:(?!:[0-9]{2,3}[A-Z]?:).)*?3\/([A-Z]{2})";
string input = @"some noise :50F: some noise 3/GB some noise :50A:
some noise :50F: some noise some noise :50A: 3/GB
some noise :50F: some : noise 3/GB some noise :50A: ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}