use strict;
my $str = 'some noise :50F: some noise 3/GB some noise :50A:
some noise :50F: some noise some noise :50A: 3/GB
some noise :50F: some : noise 3/GB some noise :50A: ';
my $regex = qr/50F:(?:(?!:[0-9]{2,3}[A-Z]?:).)*?3\/([A-Z]{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}