re = /50F:(?:(?!:[0-9]{2,3}[A-Z]?:).)*?3\/([A-Z]{2})/m
str = 'some noise :50F: some noise 3/GB some noise :50A:
some noise :50F: some noise some noise :50A: 3/GB
some noise :50F: some : noise 3/GB some noise :50A: '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end