import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "50F:(?:(?!:[0-9]{2,3}[A-Z]?:).)*?3\\/([A-Z]{2})";
final String string = "some noise :50F: some noise 3/GB some noise :50A: \n"
+ "some noise :50F: some noise some noise :50A: 3/GB \n"
+ "some noise :50F: some : noise 3/GB some noise :50A: ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}