import re
regex = re.compile(r"50F:(?:(?!:[0-9]{2,3}[A-Z]?:).)*?3\/([A-Z]{2})", flags=re.MULTILINE)
test_str = ("some noise :50F: some noise 3/GB some noise :50A: \n"
"some noise :50F: some noise some noise :50A: 3/GB \n"
"some noise :50F: some : noise 3/GB some noise :50A: ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")