const regex = new RegExp('50F:(?:(?!:[0-9]{2,3}[A-Z]?:).)*?3\\/([A-Z]{2})', 'gm')
const str = `some noise :50F: some noise 3/GB some noise :50A:
some noise :50F: some noise some noise :50A: 3/GB
some noise :50F: some : noise 3/GB some noise :50A: `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}