# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w+(bolo)\w+(farinha)\w+(acucar)\w+/\1\2\3/;t' <<< "xxxxxxxxboloxxxxxxxfarinhaxxxxxxacucarxxxx"