using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(bolo)\w+(farinha)\w+(acucar)\w+";
string substitution = @"\1\2\3";
string input = @"xxxxxxxxboloxxxxxxxfarinhaxxxxxxacucarxxxx";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}