const regex = /\w+(bolo)\w+(farinha)\w+(acucar)\w+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+(bolo)\\w+(farinha)\\w+(acucar)\\w+', '')
const str = `xxxxxxxxboloxxxxxxxfarinhaxxxxxxacucarxxxx`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);