#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\w+(bolo)\w+(farinha)\w+(acucar)\w+"
Local $sString = "xxxxxxxxboloxxxxxxxfarinhaxxxxxxacucarxxxx"
Local $sSubst = "\1\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)