// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w+(bolo)\w+(farinha)\w+(acucar)\w+").unwrap();
let string = "xxxxxxxxboloxxxxxxxfarinhaxxxxxxacucarxxxx";
let substitution = "\\1\\2\\3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}