$re = '/\w+(bolo)\w+(farinha)\w+(acucar)\w+/';
$str = 'xxxxxxxxboloxxxxxxxfarinhaxxxxxxacucarxxxx';
$subst = "\1\2\3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;