re = /\w+(bolo)\w+(farinha)\w+(acucar)\w+/
str = 'xxxxxxxxboloxxxxxxxfarinhaxxxxxxacucarxxxx'
subst = '\\1\\2\\3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result