# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^NAME : |\G(?!^))\w+\K\h/_/gm;t' <<< "NAME : john doe smith
BLAH : Blah blah"