re = /(?:^NAME : |\G(?!^))\w+\K\h/m
str = 'NAME : john doe smith
BLAH : Blah blah'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result