use strict;
my $str = 'NAME : john doe smith
BLAH : Blah blah';
my $regex = qr/(?:^NAME : |\G(?!^))\w+\K\h/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";