using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^NAME : |\G(?!^))\w+\K\h";
string substitution = @"_";
string input = @"NAME : john doe smith
BLAH : Blah blah";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}