#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^NAME : |\G(?!^))\w+\K\h"
Local $sString = "NAME : john doe smith" & @CRLF & _
"BLAH : Blah blah"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)