$re = '/(?:^NAME : |\G(?!^))\w+\K\h/m';
$str = 'NAME : john doe smith
BLAH : Blah blah';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;