import re
regex = re.compile(r"(?:^NAME : |\G(?!^))\w+\K\h", flags=re.MULTILINE)
test_str = ("NAME : john doe smith\n"
"BLAH : Blah blah")
subst = "_"
result = regex.sub(subst, test_str)
if result:
print(result)