#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:trGet|tr|trGetAndEscapeSingleQuotes)\(('|")((.|\n)+?[^\\])\1(?:\,|\))"
Local $sString = "trGet("blaa1");" & @CRLF & _
"" & @CRLF & _
"tr("blaaa");" & @CRLF & _
"" & @CRLF & _
"trGet("blaasdas's ");" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"trGet('single quote');" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"tr("matches");" & @CRLF & _
"" & @CRLF & _
"trGetAndEscapeSingleQuotes("multiline " & @CRLF & _
"" & @CRLF & _
"mit 'single line' quote drin" & @CRLF & _
"" & @CRLF & _
"hier");" & @CRLF & _
"" & @CRLF & _
"trGet("so hier mit backslash\", funtzt auch");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")