const regex = /(?:trGet|tr|trGetAndEscapeSingleQuotes)\(('|")((.|\n)+?[^\\])\1(?:\,|\))/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:trGet|tr|trGetAndEscapeSingleQuotes)\\((\'|")((.|\\n)+?[^\\\\])\\1(?:\\,|\\))', 'gim')
const str = `trGet("blaa1");
tr("blaaa");
trGet("blaasdas's ");
trGet('single quote');
tr("matches");
trGetAndEscapeSingleQuotes("multiline
mit 'single line' quote drin
hier");
trGet("so hier mit backslash\\", funtzt auch");`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}