import Foundation
let pattern = #"(?:trGet|tr|trGetAndEscapeSingleQuotes)\(('|")((.|\n)+?[^\\])\1(?:\,|\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
trGet("blaa1");
tr("blaaa");
trGet("blaasdas's ");
trGet('single quote');
tr("matches");
trGetAndEscapeSingleQuotes("multiline
mit 'single line' quote drin
hier");
trGet("so hier mit backslash\", funtzt auch");
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)