using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:trGet|tr|trGetAndEscapeSingleQuotes)\(('|"")((.|\n)+?[^\\])\1(?:\,|\))";
string input = @"trGet(""blaa1"");
tr(""blaaa"");
trGet(""blaasdas's "");
trGet('single quote');
tr(""matches"");
trGetAndEscapeSingleQuotes(""multiline
mit 'single line' quote drin
hier"");
trGet(""so hier mit backslash\"", funtzt auch"");";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}