# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w*)lan(\w+)/$1<--->$2/g;t' <<< "plan plans lander planitia"