#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(keep\d+\s*{[^}]*})|.+?"
Local $sString = "blah blah Bob Loblaw Law blah" & @CRLF & _
"keep1 { i want this } blop" & @CRLF & _
"blah blob keep2 { and" & @CRLF & _
"this too } blaw blat" & @CRLF & _
"ab ef"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)