$re = '/\b(keep\d+\s*{[^}]*})|.+?/m';
$str = 'blah blah Bob Loblaw Law blah
keep1 { i want this } blop
blah blob keep2 { and
this too } blaw blat
ab ef';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;