use strict;
my $str = 'blah blah Bob Loblaw Law blah
keep1 { i want this } blop
blah blob keep2 { and
this too } blaw blat
ab ef';
my $regex = qr/\b(keep\d+\s*{[^}]*})|.+?/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";