const regex = /\b(keep\d+\s*{[^}]*})|.+?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(keep\\d+\\s*{[^}]*})|.+?', 'gm')
const str = `blah blah Bob Loblaw Law blah
keep1 { i want this } blop
blah blob keep2 { and
this too } blaw blat
ab ef`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);