package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(keep\d+\s*{[^}]*})|.+?`)
var str = `blah blah Bob Loblaw Law blah
keep1 { i want this } blop
blah blob keep2 { and
this too } blaw blat
ab ef`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}