#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^([-\p{L}_&]+)[\s]+\1(\W)"
Local $sString = "Баден&Баден " & @CRLF & _
"K&K" & @CRLF & _
"Top Top" & @CRLF & _
"Букет Букет Букет невесты Констанция" & @CRLF & _
"Букет,Букет Букет невесты Констанция" & @CRLF & _
"Top Top" & @CRLF & _
"D101, fdf1 " & @CRLF & _
"ААА А АА А А А, Сумка 6030 Amethyst" & @CRLF & _
"1212, 3232" & @CRLF & _
"Букет100, невесты невесты& Букет невесты Жюльет" & @CRLF & _
"B2 fd B " & @CRLF & _
"xbckj 1 b xxbckj 2 f Njg100 Njg " & @CRLF & _
"в в " & @CRLF & _
" -B Конструктор Конструктор, Конструктор Chicco, Конструктор 5 в 1 Машины (40 деталей)" & @CRLF & _
"Баден&Баден " & @CRLF & _
"" & @CRLF & _
"Букет Букет," & @CRLF & _
"Баден-Баден " & @CRLF & _
"К & K" & @CRLF & _
"----" & @CRLF & _
"Дочки и Сыночки" & @CRLF & _
"2323-232-в" & @CRLF & _
"Инфа" & @CRLF & _
"" & @CRLF & _
"Mert-Mert " & @CRLF & _
"Mert, Mert" & @CRLF & _
"D&D" & @CRLF & _
"1.1 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")