import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([-\\p{L}_&]+)[\\s]+\\1(\\W)";
final String string = "Баден&Баден \n"
+ "K&K\n"
+ "Top Top\n"
+ "Букет Букет Букет невесты Констанция\n"
+ "Букет,Букет Букет невесты Констанция\n"
+ "Top Top\n"
+ "D101, fdf1 \n"
+ "ААА А АА А А А, Сумка 6030 Amethyst\n"
+ "1212, 3232\n"
+ "Букет100, невесты невесты& Букет невесты Жюльет\n"
+ "B2 fd B \n"
+ "xbckj 1 b xxbckj 2 f Njg100 Njg \n"
+ "в в \n"
+ " -B Конструктор Конструктор, Конструктор Chicco, Конструктор 5 в 1 Машины (40 деталей)\n"
+ "Баден&Баден \n\n"
+ "Букет Букет,\n"
+ "Баден-Баден \n"
+ "К & K\n"
+ "----\n"
+ "Дочки и Сыночки\n"
+ "2323-232-в\n"
+ "Инфа\n\n"
+ "Mert-Mert \n"
+ "Mert, Mert\n"
+ "D&D\n"
+ "1.1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}