using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([-\p{L}_&]+)[\s]+\1(\W)";
string input = @"Баден&Баден
K&K
Top Top
Букет Букет Букет невесты Констанция
Букет,Букет Букет невесты Констанция
Top Top
D101, fdf1
ААА А АА А А А, Сумка 6030 Amethyst
1212, 3232
Букет100, невесты невесты& Букет невесты Жюльет
B2 fd B
xbckj 1 b xxbckj 2 f Njg100 Njg
в в
-B Конструктор Конструктор, Конструктор Chicco, Конструктор 5 в 1 Машины (40 деталей)
Баден&Баден
Букет Букет,
Баден-Баден
К & K
----
Дочки и Сыночки
2323-232-в
Инфа
Mert-Mert
Mert, Mert
D&D
1.1 ";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}