const regex = /^([-\p{L}_&]+)[\s]+\1(\W)/ugm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([-\\p{L}_&]+)[\\s]+\\1(\\W)', 'ugm')
const str = `Баден&Баден
K&K
Top Top
Букет Букет Букет невесты Констанция
Букет,Букет Букет невесты Констанция
Top Top
D101, fdf1
ААА А АА А А А, Сумка 6030 Amethyst
1212, 3232
Букет100, невесты невесты& Букет невесты Жюльет
B2 fd B
xbckj 1 b xxbckj 2 f Njg100 Njg
в в
-B Конструктор Конструктор, Конструктор Chicco, Конструктор 5 в 1 Машины (40 деталей)
Баден&Баден
Букет Букет,
Баден-Баден
К & K
----
Дочки и Сыночки
2323-232-в
Инфа
Mert-Mert
Mert, Mert
D&D
1.1 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}