import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^([-\p{L}_&]+)[\s]+\1(\W)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Баден&Баден
K&K
Top Top
Букет Букет Букет невесты Констанция
Букет,Букет Букет невесты Констанция
Top Top
D101, fdf1
ААА А АА А А А, Сумка 6030 Amethyst
1212, 3232
Букет100, невесты невесты& Букет невесты Жюльет
B2 fd B
xbckj 1 b xxbckj 2 f Njg100 Njg
в в
-B Конструктор Конструктор, Конструктор Chicco, Конструктор 5 в 1 Машины (40 деталей)
Баден&Баден
Букет Букет,
Баден-Баден
К & K
----
Дочки и Сыночки
2323-232-в
Инфа
Mert-Mert
Mert, Mert
D&D
1.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)