#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(?!^)\d\b"
Local $sString = "1. Задача, сделать что-то до 28.08. 2. Разобраться с замыканиями."
Local $sSubst = "\n$&"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)