$re = '/\b(?!^)\d\b/m';
$str = '1. Задача, сделать что-то до 28.08. 2. Разобраться с замыканиями.';
$subst = "\n$&";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;