using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!^)\d\b";
string substitution = @"\n$&";
string input = @"1. Задача, сделать что-то до 28.08. 2. Разобраться с замыканиями.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}