re = /\b(?!^)\d\b/m
str = '1. Задача, сделать что-то до 28.08. 2. Разобраться с замыканиями.'
subst = '\\n$&'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result