import re
regex = re.compile(r"\b(?!^)\d\b", flags=re.MULTILINE)
test_str = "1. Задача, сделать что-то до 28.08. 2. Разобраться с замыканиями."
subst = "\\n$&"
result = regex.sub(subst, test_str)
if result:
print(result)