import Foundation
let pattern = #"\b(?!^)\d\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1. Задача, сделать что-то до 28.08. 2. Разобраться с замыканиями."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$&"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)